Browse Source

Fix tests for sqlite

- sqlite executable used by ob-sqlite is 'sqlite3'
- require ob-sqlite for test
Robert Klein 7 months ago
parent
commit
1e6ab19b2a
1 changed files with 2 additions and 1 deletions
  1. 2 1
      testing/lisp/test-ob-sqlite.el

+ 2 - 1
testing/lisp/test-ob-sqlite.el

@@ -19,7 +19,8 @@
 ;; along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
 ;;; Code:
-(org-test-for-executable "sqlite")
+(org-test-for-executable "sqlite3")
+(require 'ob-sqlite)
 (unless (featurep 'ob-sqlite)
   (signal 'missing-test-dependency "Support for sqlite code blocks"))