Browse Source

change requirement order to ob-eval is always loaded

* lisp/ob-eval.el (require): No longer require ob.el to allow
  requiring by ob.el.
* lisp/ob.el (ob-eval): Require ob-eval.
Eric Schulte 10 years ago
parent
commit
a9a77780dc
2 changed files with 1 additions and 2 deletions
  1. 0 1
      lisp/ob-eval.el
  2. 1 1
      lisp/ob.el

+ 0 - 1
lisp/ob-eval.el

@@ -28,7 +28,6 @@
 ;; shell commands.
 
 ;;; Code:
-(require 'ob)
 (eval-when-compile (require 'cl))
 
 (defvar org-babel-error-buffer-name "*Org-Babel Error Output*")

+ 1 - 1
lisp/ob.el

@@ -32,6 +32,7 @@
 (eval-when-compile
   (require 'org-list)
   (require 'cl))
+(require 'ob-eval)
 (require 'org-macs)
 
 (defvar org-babel-call-process-region-original)
@@ -78,7 +79,6 @@
 (declare-function org-list-to-generic "org-list" (LIST PARAMS))
 (declare-function org-list-bottom-point "org-list" ())
 
-(declare-function org-babel-eval-wipe-error-buffer "ob-eval" ())
 (defgroup org-babel nil
   "Code block evaluation and management in `org-mode' documents."
   :tag "Babel"