Browse Source

Use cl-lib rather than cl variants in org-drill

org-drill requires only cl-lib rather than cl, so should use cl-gensym
rather than gensym I believe.

From 1eef99d550e467bf4a3eaf6bdbe4d3a482f6c187 Mon Sep 17 00:00:00 2001
From: Stig Brautaset <stig@brautaset.org>
Date: Fri, 14 Jul 2017 20:45:37 +0100
Subject: [PATCH 2/3] org-drill.el: use cl-gensym rather than gensym

cl-lib is already required by this file, but cl is not.
Stig Brautaset 2 years ago
parent
commit
a49e146621
1 changed files with 1 additions and 1 deletions
  1. 1 1
      contrib/lisp/org-drill.el

+ 1 - 1
contrib/lisp/org-drill.el

@@ -622,7 +622,7 @@ regardless of whether the test was successful.")
 
 
 (defmacro pop-random (place)
-  (let ((idx (gensym)))
+  (let ((idx (cl-gensym)))
     `(if (null ,place)
          nil
        (let ((,idx (random* (length ,place))))