Browse Source

ob-octave: Emacs 24.4 will ditch octave-inf in favor for octave

* lisp/ob-octave.el (org-babel-octave-initiate-session): If octave-inf
  can't be loaded, try octave instead before giving up.  Emacs 24.3.50
  and upwards replaces octave-inf with just plain octave.
Achim Gratz 4 years ago
parent
commit
885d1d6786
1 changed files with 2 additions and 1 deletions
  1. 2 1
      lisp/ob-octave.el

+ 2 - 1
lisp/ob-octave.el

@@ -151,7 +151,8 @@ create.  Return the initialized session."
   "Create an octave inferior process buffer.
 If there is not a current inferior-process-buffer in SESSION then
 create.  Return the initialized session."
-  (if matlabp (require 'matlab) (require 'octave-inf))
+  (if matlabp (require 'matlab) (or (require 'octave-inf nil 'noerror)
+				    (require 'octave)))
   (unless (string= session "none")
     (let ((session (or session
 		       (if matlabp "*Inferior Matlab*" "*Inferior Octave*"))))