Browse Source

ob-js.el: Fix obsolete requirement

* lisp/ob-js.el (org-babel-js-function-wrapper): Fix obsolete
requirement.

TINYCHANGE
Ivan Sokolov 2 months ago
parent
commit
47b653450f
1 changed files with 1 additions and 1 deletions
  1. 1 1
      lisp/ob-js.el

+ 1 - 1
lisp/ob-js.el

@@ -65,7 +65,7 @@
   :safe #'stringp)
 
 (defvar org-babel-js-function-wrapper
-  "require('sys').print(require('sys').inspect(function(){\n%s\n}()));"
+  "require('process').stdout.write(require('util').inspect(function(){%s}()));"
   "Javascript code to print value of body.")
 
 (defun org-babel-execute:js (body params)